Debes actualizar tu iPhone viejo o ya no podrás utilizar el GPS

La compañía de la manzana ha anunciado una actualización para los iPhone e iPad que salieron al mercado antes del 2012. Si bien estos equipos ya no pueden recibir la última versión de su sistema operativo (iOS 12), deben actualizarse con un nuevo parche o, de lo contrario, la función GPS dejará de funcionar en ellos.

De esta manera, para el iPhone 5 y el iPad de cuarta generación la actualización se mostrará como iOS 10.3.4, mientras que para el iPhone 4s, el iPad mini de primera generación, el iPad 2 y el iPad de tercera generación, se mostrará como iOS 9.3.6.

Los usuarios de estos modelos tendrán hasta el 3 de noviembre para realizar el reajuste si no quieren perder la función de GPS y, con ella, la posibilidad de actualizar automáticamente la fecha y la hora del dispositivo.

¿Por qué dejará de funcionar el GPS en estos modelos antiguos?
La tecnología GPS utiliza la fecha y la hora para calcular la ubicación incluyendo el número de la semana. Según ‘The Register’, todos esos datos los almacena dentro de un sistema de “diez bits binarios” y cada 20 años ese contador vuelve a cero, por lo que el dispositivo que está intentando usar el GPS falla y la fecha le regresa a un año antes.

El pasado 6 de abril ocurrió un cambio de estas características. Esto significa que ciertos dispositivos Apple que no cuentan con la posibilidad de actualizarse a iOS 12 se podrían ver afectados por el problema a partir de noviembre.

+ +